Beta1 de WordPress 2.3.1

Actualización: Ya está disponible la versión final de WordPress 2.3.1.

Acaban de anunciar la liberación de la primera versión menor de la rama WordPress 2.3, que entre otras cosas trae las siguientes mejoras y correcciones a fallas:

  • Soporte nativo para agregar tags desde Windows Live Writer.
  • Mejora de rendimiento para realizar las intersecciones de tags y categorías.
  • Corrección de un bug en la edición y creación de páginas (no se escapaba el HTML).
  • Corrección a la vulnerabilidad -- que algunos la consideran erróneamente "grave" -- que permite a usuarios registrados agregar enlaces al blogroll, para blogs donde el registro de usuarios no está habilitado este problema es inofensivo.

Pueden ver una lista más completa de problemas solucionados en la página de registro de bugs.

Descargas

WordPress 2.3: privacidad, problemas y otros

A estas alturas supongo que seré uno de los últimos de los que aburra con este tema 😀 , pero la salida de WordPress 2.3 ha generado -- como esperaba luego de leer la lista de correo -- bastante polémica por que el nuevo sistema de actualizaciones envía ciertos datos* a api.wordpress.org.

Privacidad

A pesar de que el código para la notificación de actualizaciones está en el repositorio desde el 22 de agosto, este incidente empezó día anterior al lanzamiento de esta versión con opiniones divididas -- incluso entre los desarrolladores -- sobre si es necesario y sobre todo, si es correcto o no que éstos datos se envíen sin el consentimiento de los usuarios. Lo malo de todo este revuelo que se armó es que hasta dos horas antes del lanzamiento, ninguno de los que reclamaba que quitaran esta característica propuso un parche; por otro lado también hubo respuestas inadecuadas por parte de Matt Mullenweg, en especial esta:

If you don’t trust wordpress.org, I suggest you do one of the following:

  • Use different software.
  • Fork WordPress.
  • Install one of the aforementioned plugins.

Problemas

Esta versión trae consigo importantes cambios en el esquema de la base de datos, por lo que es necesario antes de actualizar, asegurarse que los plugins y tema usados sean compatibles.

Andrés recopiló una serie de errores que muchos usuarios parecen compartir, adicionalmente a esto si alguien se encuentra con el siguiente error no tiene porque preocuparse (probablemente es parte de un bug antiguo que permitía agregar dos veces la misma categoría a una entrada).

code:
WordPress database error: [Duplicate entry 'post_id-category_id' for key 1]
INSERT INTO wp_term_relationships (object_id, term_taxonomy_id)
VALUES ('post_id', 'category_id')

Personalmente les sugiero que primero hagan pruebas locales antes de actualizar sus blogs, pueden seguir el artículo "5 Step Failsafe upgrade for WordPress" para esto, pero sólo tomen en cuenta los últimos cuatro pasos (por ningún motivo realicen el paso 1 con la alternativa que se menciona ahí, o al menos no lo mantengan activado luego de terminar de actualizar).

Consumo de memoria

Me ha llamado la atención otra vez los datos que publica Andrés con respecto al incremento de memoria de WordPress 2.3, según sus pruebas esta última versión consume casi el doble de memoria que la anterior versión:

code:
//Wordpress 2.2
Memoria usada: 2981.4 KB de 3328 KB

//Wordress 2.3
Memoria usada: 6743.2 KB de 6912 KB

Personalmente creo que hay algo raro en su entorno de pruebas 🙂 , puesto que tanto en DreamHost, en este servidor y la máquina virtual que uso, WordPress 2.2 recién instalado y con el tema por omisión consume alrededor de 4530 KB y WordPress 2.3 está por los 5180 KB, con lo cual el incremento de memoria no es tan dramático para blogs pequeños como éste (blogs más populares tampoco tienen porque preocuparse si usan wp-cache).

Una forma de reducir un poco más el consumo de memoria de blogs que usan archivos de traducción, es traducir sólo el texto necesario (fechas principalmente) y eliminar las demás palabras, pueden descargar estos archivos que actualmente uso para el blog:

Continue reading "WordPress 2.3: privacidad, problemas y otros"

Habilitar el soporte de Tags en Windows Live Writer para WordPress 2.3

Actualización: Existe una versión un poco más completa de este archivo en http://trac.wordpress.org/ticket/5023.

Para habilitar el soporte de tags en Windows Live Writer para blogs que usan WordPress 2.3, simplemente tienen que subir un fichero con el nombre wlwmanifest.xml en la raíz de vuestros blogs o pueden especificar una ruta distinta del siguiente modo:

html:
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="ruta/wlwmanifest.xml" />

El mencionado fichero contiene una serie de propiedades que permiten personalizar la funcionalidad de Windows Live Writer:

xml:
<?xml version="1.0" encoding="UTF-8"?>
<manifest xmlns="http://schemas.microsoft.com/wlw/manifest/weblog">
        <options>
              <supportsKeywords>Yes</supportsKeywords>
                <supportsFileUpload>Yes</supportsFileUpload>
                <supportsExtendedEntries>Yes</supportsExtendedEntries>
                <supportsCustomDate>Yes</supportsCustomDate>
                <supportsCategories>Yes</supportsCategories>
                <supportsCategoriesInline>Yes</supportsCategoriesInline>
                <supportsMultipleCategories>Yes</supportsMultipleCategories>
                <supportsHierarchicalCategories>Yes</supportsHierarchicalCategories>
                <supportsNewCategories>Yes</supportsNewCategories>
                <supportsNewCategoriesInline>Yes</supportsNewCategoriesInline>
                <supportsCommentPolicy>Yes</supportsCommentPolicy>
                <supportsPingPolicy>Yes</supportsPingPolicy>
                <supportsAuthor>Yes</supportsAuthor>
                <supportsSlug>Yes</supportsSlug>
                <supportsPassword>Yes</supportsPassword>
                <supportsExcerpt>Yes</supportsExcerpt>
                <supportsTrackbacks>Yes</supportsTrackbacks>
                <supportsPages>Yes</supportsPages>
                <supportsPageParent>Yes</supportsPageParent>
                <supportsPageOrder>Yes</supportsPageOrder>
                <requiresXHTML>True</requiresXHTML>
                <supportsAutoUpdate>No</supportsAutoUpdate>
        </options>
        <weblog>
                <homepageLinkText>View your blog</homepageLinkText>
                <adminLinkText>Administer your blog</adminLinkText>
                <adminUrl><![CDATA[
                        {blog-homepage-url}wp-admin
                ]]></adminUrl>
                <postEditingUrl><![CDATA[
                        {blog-homepage-url}wp-admin/edit.php
                ]]></postEditingUrl>
        </weblog>
</manifest>

Las dos líneas resaltadas tienen la siguiente función:

  • requiresXHTML: indica a Windows Live Writer que el contenido debe validar XHTML. Al habilitar esta característica, todas las tildes y algunos caracteres típicos de nuestro idioma serán convertidos a entidades HTML (Ej. á => &#xE1; ), por otro lado, esta opción no asegura que el código generado será completamente válido.
  • supportsAutoUpdate: al habilitar esta característica, Windows Live Writer verificará continuamente si el archivo wlwmanifest.xml cambió. Si desean ahorrar un poco de ancho de banda, es mejor deshabilitado.

Descargar Windows Live Writer Manifest.

Nueva actualización: WordPress 2.3

Luego de pedir que me habilitaran el acceso por SSH y poner la página de mantenimiento del blog por unas horas, finalmente terminé de modificar algunos plugins y parte de los temas que uso para que sean compatibles con WordPress 2.3, pero esta vez, para facilitar las actualizaciones futuras, estoy usando una rama del servidor de control de versiones de WordPress. 😉

El proceso de actualización es -- como siempre -- simple y por suerte para mi, los temas y casi todos los plugins que uso eran compatibles con WordPress 2.3, sólo tuve que agregar cierta funcionalidad al plugin "All in One SEO Pack".

Si notan algo raro y tienen algo de tiempo para reportarlo, les agradezco de antemano su colaboración. 🙂